JEEPTALK.net: Jeeps running bad - JEEPTALK.net

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Jeeps running bad

#1 User is offline   MuleyBoy 

  • Sergeant
  • Group: Members
  • Posts: 21
  • Joined: 11-September 11
  • Gender:Male
  • Location:Tollhouse, CA

Posted 17 September 2011 - 05:33 PM

Uggh! Was heading up deer hunting yesterday and my Jeep started running bad...it runs fine at low speed, but when I get going faster it falls on its face and tries to die! I thought it was the electric fuel pump because it recently started making noise! I changed the fuel pump, loaded up the hunting gear and the kids and started to camp and jeep started its crap again! I checked the fuel filters, they're fine....I have a 71 cj5 with a buick 225 6 cyl! Help because im mechanically challenged!

#2 User is offline   Big Red One 

  • First Lieutenant
  • View gallery
  • Group: Members
  • Posts: 316
  • Joined: 26-October 09
  • Gender:Male
  • Location:Miami, FL

Posted 17 September 2011 - 09:00 PM

Had a similar problem on the Jeep 258 years ago, found to be the ignition module, mine has a low AND a high speed circuit, one can go bad with the other being OK... Took it to the Auto Parts store and had it tested. :2:
89 YJ, AMC 360, 102" OF NOISE AND BOOGER WELDS
MAKING GOOD DECISIONS COMES FROM EXPERIENCE ...
EXPERIENCE COMES FROM MAKING BAD DECISIONS ...

#3 User is offline   XrayDivr 

  • First Lieutenant
  • Group: Members
  • Posts: 480
  • Joined: 02-January 07
  • Gender:Male
  • Location:Ft. Laud.,FL & Wisconsin

Posted 18 September 2011 - 07:52 AM

thats along the same line of what i was thinking except if you dont have an electric ignition i was thinking vacuum advance on the distributer
president: jubicon express off-road

at jubicon express i'm not only the president but i'm also a client.

#4 User is offline   MuleyBoy 

  • Sergeant
  • Group: Members
  • Posts: 21
  • Joined: 11-September 11
  • Gender:Male
  • Location:Tollhouse, CA

Posted 19 September 2011 - 07:39 AM

Thanks y'all, its fixed now! It was the fuel filter! I started tearing the fuel line apart at the carb and turned the new pump on and fuel was just trickeling out so I went back to the fuel regulator and it was pooring out from that point! Room the in-line fuel filter apart plugged one side with my finger and filled it with water.....water didn't leak out so then I tried blowing through it and that didn't work either! Put a new screen in it and she runs like a striped assed ape now! Filter looked fine but it was sure clogged! Lesson learned!

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Miami Jeep Fort Lauderdale Jeep Dealer